Browse Source

Bump sinatra version since 2.0.0 is insecure

master
IamTheFij 1 year ago
parent
commit
eabe2af9b1
4 changed files with 17 additions and 17 deletions
  1. +1
    -1
      parsers/package-tracking/Gemfile
  2. +7
    -7
      parsers/package-tracking/Gemfile.lock
  3. +1
    -1
      viewers/package-tracking/Gemfile
  4. +8
    -8
      viewers/package-tracking/Gemfile.lock

+ 1
- 1
parsers/package-tracking/Gemfile View File

@@ -2,4 +2,4 @@ source 'https://rubygems.org'
ruby '2.5'

gem 'tracking_number', '1.0.3'
gem 'sinatra', '2.0'
gem 'sinatra', '2.0.1'

+ 7
- 7
parsers/package-tracking/Gemfile.lock View File

@@ -1,23 +1,23 @@
GEM
remote: https://rubygems.org/
specs:
activesupport (5.1.4)
activesupport (5.1.5)
concurrent-ruby (~> 1.0, >= 1.0.2)
i18n (~> 0.7)
minitest (~> 5.1)
tzinfo (~> 1.1)
concurrent-ruby (1.0.5)
i18n (0.9.4)
i18n (0.9.5)
concurrent-ruby (~> 1.0)
minitest (5.11.3)
mustermann (1.0.1)
mustermann (1.0.2)
rack (2.0.4)
rack-protection (2.0.0)
rack-protection (2.0.1)
rack
sinatra (2.0.0)
sinatra (2.0.1)
mustermann (~> 1.0)
rack (~> 2.0)
rack-protection (= 2.0.0)
rack-protection (= 2.0.1)
tilt (~> 2.0)
thread_safe (0.3.6)
tilt (2.0.8)
@@ -30,7 +30,7 @@ PLATFORMS
ruby

DEPENDENCIES
sinatra (= 2.0)
sinatra (= 2.0.1)
tracking_number (= 1.0.3)

RUBY VERSION

+ 1
- 1
viewers/package-tracking/Gemfile View File

@@ -2,4 +2,4 @@ source 'https://rubygems.org'
ruby '2.5'

gem 'trackerific', '0.8.0'
gem 'sinatra', '2.0'
gem 'sinatra', '2.0.1'

+ 8
- 8
viewers/package-tracking/Gemfile.lock View File

@@ -1,7 +1,7 @@
GEM
remote: https://rubygems.org/
specs:
activesupport (5.1.4)
activesupport (5.1.5)
concurrent-ruby (~> 1.0, >= 1.0.2)
i18n (~> 0.7)
minitest (~> 5.1)
@@ -13,23 +13,23 @@ GEM
concurrent-ruby (1.0.5)
gyoku (1.1.1)
builder (>= 2.1.2)
httparty (0.15.7)
httparty (0.16.0)
multi_xml (>= 0.5.2)
httpi (2.1.1)
rack
rubyntlm (~> 0.3.2)
i18n (0.9.4)
i18n (0.9.5)
concurrent-ruby (~> 1.0)
mime-types (1.25.1)
mini_portile2 (2.3.0)
minitest (5.11.3)
multi_xml (0.6.0)
mustermann (1.0.1)
mustermann (1.0.2)
nokogiri (1.8.2)
mini_portile2 (~> 2.3.0)
nori (2.3.0)
rack (2.0.4)
rack-protection (2.0.0)
rack-protection (2.0.1)
rack
rubyntlm (0.3.4)
savon (2.3.3)
@@ -40,10 +40,10 @@ GEM
nokogiri (>= 1.4.0)
nori (~> 2.3.0)
wasabi (~> 3.2.2)
sinatra (2.0.0)
sinatra (2.0.1)
mustermann (~> 1.0)
rack (~> 2.0)
rack-protection (= 2.0.0)
rack-protection (= 2.0.1)
tilt (~> 2.0)
thread_safe (0.3.6)
tilt (2.0.8)
@@ -63,7 +63,7 @@ PLATFORMS
ruby

DEPENDENCIES
sinatra (= 2.0)
sinatra (= 2.0.1)
trackerific (= 0.8.0)

RUBY VERSION

Loading…
Cancel
Save